Hyperz Documentation > Products > Verbatim > Front End

Front End

Hyperz

Frontend Development

Install

npm install hyperz-verbatim

Verbatim Interpreter

const verbatim = require('hyperz-verbatim').setExtension('.ext'); // Imports the module and sets the custom extension.

// This is a prime example of just running files, instead of using require()
verbatim.runBytecodeFile('/path/to/your/file.ext'); // Runs the file
verbatim.runBytecode(code); // Runs provided bytecode

// Make sure if you are using 'require()' for your file, that you compiled it AS A MODULE to import exports etc.
let bruh = require('./backend.ext');
bruh.run("Hello World!");


Was this article helpful?

114 out of 211 found this helpful